Yes. You are required to download and use the latest version of the app. It has important fixes required for smoother flow.